Задать вопрос
1 января, 18:06

Задачи по теме массив

1. В массиве хранятся сведения об оценках 25 учеников по химии. Определить количество неуспевающих по химии учеников.

2. В мвссиве хранятся сведения об общей стоимости товаров, проданных фирмой за каждый день марта. Определить количество дней, в которые стоимость проданных товаров превысила значение S.

+3
Ответы (1)
  1. 1 января, 21:16
    0
    1. var a:array[1 ... 100] of integer;

    i, s:integer;

    begin

    for i:=1 to 25 do begin

    a[i]:=random (5) + 1;

    write (a[i]:4) ;

    end;

    s:=0;

    for i:=1 to 25 do begin

    if a[i]<=2 then s:=s+1;

    end;

    writeln;

    writeln ('Количество неуспевающих=', s) ;

    end.

    это при условии, что человек неуспевающий, если у него оценка ниже или равна 2-ке
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задачи по теме массив 1. В массиве хранятся сведения об оценках 25 учеников по химии. Определить количество неуспевающих по химии учеников. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В массиве хранятся сведения об общей стоимости товаров, проданных фирмой за каждый день марта. Определить дни, в которые стоимость проданных товаров превысила значение S.
Ответы (1)
Фирме принадлежат два магазина. Известна стоимость товаров, проданных в каждом магазине за каждый день в июле и в августе, которая хранится в двух массивах. Получить общую стоимость проданных фирмой товаров за два месяца.
Ответы (1)
1. Дан массив натуральных чисел. Вывести на экран все двухзначные числа. 2. В массиве хранятся сведенья об оценках 25-ти учеников по английскому языку. Определить количество "5", "4", "3", "2".
Ответы (2)
В двухмерном массиве в строках хранится информация об оценках каждого из 20 учеников класса по тому или иному предмету (в первой строке - информация об оценках первого ученика, во второй - второго и т. д.). Общее число предметов равно 10.
Ответы (1)
В массиве хранятся сведения о количестве осадков, выпавших за 10 дней июня. Написать программу, которая определяет общее количество осадков за 10 дней. Массив должен вводиться во время работы программы.
Ответы (1)