Задать вопрос
23 июня, 23:00

Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A, B ] и определяет номера двух элементов этого массива, которые расположены ближе всех друг к другу на числовой оси. Эти элементы не обязательно должны быть расположены рядом друг с другом. Если таких пар несколько, нужно вывести номера элементов самой последней из таких найденных пар.

Входные данные

Входная строка содержит три числа: границы диапазона случайных чисел A и B, а также размер массива N. Все числа разделены пробелами. Гарантируется, что 0 < N ≤ 10000.

+3
Ответы (1)
  1. 24 июня, 02:54
    0
    Const

    n = 50; / / количество чиселvar

    k: array [1 ... n] of integer;

    i, j, n1, n2, minr, A, B: integer; begin

    writeln (n, ' ', ':D') ;

    A : = random (1000) ;

    B : = random (1000) ;

    minr : = 10000;

    for i : = 1 to n do

    k[i] : = A + random (B) ;

    for i : = 1 to n do

    for j : = 1 to n do

    if ((abs (k[i] - k[j])) < minr) and (k[i] k[j]) then

    begin

    minr : = abs (k[i] - k[j]) ;

    n1 : = i;

    n2 : = j;

    end;

    writeln (n1, ' ', n2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A, B ] и определяет номера двух ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A, B ] и определяет среднее арифметическое элементов этого массива.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива. В третьей строке записано число X.
Ответы (1)
Pascal ABC Напишите программу, которая находит три наименьших элемента массива и переставляет их в начало массива. Остальные элементы должны следовать далее в том же порядке. Входные данные Первая строка содержит размер массива N.
Ответы (1)