Задать вопрос
26 июня, 11:08

Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A, B ] и определяет среднее арифметическое элементов этого массива.

Входные данные

Входная строка содержит три числа: границы диапазона случайных чисел A и B, а также размер массива N. Все числа разделены пробелами. Гарантируется, что 0 < N ≤ 10000.

Выходные данные

В первой строке программа должна вывести N элементов построенного массива, разделив их пробелами, а во второй строке - среднее арифметическое элементов этого массива, сохранив три знака в дробной части.

+4
Ответы (1)
  1. 26 июня, 14:24
    -1
    Var

    c:array[1 ... 100] of integer;

    i, n, k, S, a, b: integer; q: real;

    begin

    read (n) ; read (a) ; read (b) ; k:=0; S:=S;

    for i:=1 to n do begin

    a[i]:=random (a, b) ;

    k:=k+1; S:=S+a[i]; write (a[i], ' ') ; end;

    q:=S/k;

    writeln (q:17:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A, B ] и определяет среднее ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A, B ] и определяет номера двух элементов этого массива, которые расположены ближе всех друг к другу на числовой оси.
Ответы (1)
Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива. В третьей строке записано число X.
Ответы (1)
Напишите программу, которая выбирает в другой массив каждый третий элемент исходного массива, начиная с первого. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Python Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)