Задать вопрос
4 октября, 15:14

Составить программу которая находит корни неполного квадратного уравнения

+3
Ответы (1)
  1. 4 октября, 19:04
    0
    Program koren;

    var a, b, c, diskr, x1, x2:real;

    begin

    readln (a, b, c) ;

    if a=0 then exit;

    diskr:=b*b-4*a*c;

    if diskr<0 then exit;

    x1: = (-b-sqrt (diskr)) / (2*a)) ;

    x1: = (-b+sqrt (diskr)) / (2*a)) ;

    writeln (x1, x2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу которая находит корни неполного квадратного уравнения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Составьте программу которая формирует массив из 16 случайных чисел от - 20 до 20 и: а) находит элементы с нулевыми значениями б) находит индексы четных элементов в) подсчитывает количество отрицательных элементов г) определяет, есть ли в этом
Ответы (1)
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
На языке программирования Паскаль напишите программу, которая: 1) В последовательности чисел находит количество чисел, кратных 3. 2) В последовательности чисел находит максимальное четное число, оканчивающееся на 4.
Ответы (1)