Задать вопрос
28 марта, 19:24

Дано натуральное число N. Выведите его представление в двоичном виде в обратном порядке. Pascal ABC

+2
Ответы (1)
  1. 28 марта, 22:01
    0
    Var n:integer;

    begin

    write ('n = ') ; readln (n) ;

    while n0 do

    begin

    write (n mod 2) ;

    n:=n div 2;

    end;

    writeln;

    end.

    Пример:

    n = 8

    0001
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число N. Выведите его представление в двоичном виде в обратном порядке. Pascal ABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
29. Запишите в двоичном виде отрицательное однобайтное число, если соответствующее ему положительное число в двоичном виде равно 1111001
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1. Дано натуральное число m. Подсчитать количество всех 0 в числе. 2. Дано натуральное число n. Вывести это число в обратном порядке (все на языке паскаль ABC)
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)