Задать вопрос
28 февраля, 06:21

1. Дано натуральное число m. Подсчитать количество всех 0 в числе.

2. Дано натуральное число n. Вывести это число в обратном порядке

(все на языке паскаль ABC)

+2
Ответы (1)
  1. 28 февраля, 07:40
    0
    Var

    m, n:integer;

    Begin

    WriteLn ('m = ') ;

    ReadLn (m) ;

    n:=0;

    While m>0 do

    Begin

    if m mod 10 = 0 then n:=n+1;

    m:=m div 10

    End;

    WriteLn ('Кол-во нулей в данном числе равно: ', n) ;

    End.

    Var

    n:integer;

    Begin

    Write ('n = ') ;

    ReadLn (n) ;

    While n>0 do

    Begin

    Write (n mod 10) ;

    n: = n div 10

    End;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дано натуральное число m. Подсчитать количество всех 0 в числе. 2. Дано натуральное число n. Вывести это число в обратном порядке (все ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Напишите программу на паскаль. Дано число n меньше или равно 30 000. Изменяя число i от 1 до n будем записывать получившееся число подряд без пробелов, и получим некое число. Подсчитать в этом числе количество нулей, единиц, двоек до девяток.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)