Задать вопрос
21 июня, 04:01

В матрице A найти строку с наименьшим элементом и упорядочить элементы этой строки по возрастанию. Результат записать в матрицу Б. Элементы матрицы А

вычисляется по формуле a_{ij} = sinj (1-sini), где i, j=1,2 ... 10. Pascal. Через процедуры

+5
Ответы (1)
  1. 21 июня, 04:45
    0
    Const nx=20;

    var i, j, n, s:integer; A, B:array[1 ... nx, 1 ... nx] of real; min, t:real;

    z:array[1 ... nx] of real;

    begin

    min:=100;

    write ('Введите размер матрицы n') ; Readln (n) ;

    for i:=1 to n do begin

    for j:=1 to n do begin

    A[i, j]: = sin (j) * (1-sin (i)) ;

    write (A[i, j]:9:4) ;

    if min > A[i, j] then begin min: = A[i, j]; s:=i; end;

    end; writeln; end; writeln;

    i:=s;

    for j:=1 to n do begin

    z[j]:=A[i, j]; write (z[j]:9:4) ; end;

    for i:=1 to n do begin

    for j:=2 to n do begin

    if z[j-1]> z[j] then begin

    t:=z[j-1]; z[j-1]:=z[j]; z[j]:=t

    end; end; end;

    writeln;

    i:=s;

    for j:=1 to n do begin

    A[i, j]:=z[j]; write (z[j]:9:4) ; end;

    writeln; writeln;

    for i:=1 to n do begin

    for j:=1 to n do begin

    B[i, j]: = A[i, j]; write (B[i, j]:9:4) ; end;

    writeln; end;

    writeln; write ('min = ', min:9:4, ' I = ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В матрице A найти строку с наименьшим элементом и упорядочить элементы этой строки по возрастанию. Результат записать в матрицу Б. Элементы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100).
Ответы (1)
Ввести матрицу. Найти сумму четных элементов матрицы. Если она отрицательна, то заменить элементы четных столбцов матрицы на 1, в ином случае нечетных столбцов на - 1. Матрицу распечатать
Ответы (1)
В заданной матрице A (n*n) найти минимум всех сумм абсолютных величин элементов матрицы по столбцам. Использовать процедуры ввода и вывода элементов матрицы по строкам.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Напишите программу, которая находит в матрице столбцы, в которых есть элемент, равный максимальному. Входные данные В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M (1 ≤ N, M ≤ 100).
Ответы (1)