Задать вопрос
3 апреля, 15:09

Дана матрица 4 на 4 упорядочить каждыйстолбц по возрастанию методом пузырька

+3
Ответы (1)
  1. 3 апреля, 15:54
    0
    Const

    n=4;

    var

    arr: array[1 ... n, 1 ... n] of integer;

    i, j, t, buf: integer;

    begin

    for i:=1 to n do

    for j:=1 to n do

    begin

    write ('Введите элемент: ') ;

    readln (arr[i, j]) ;

    end;

    writeln ('Введеная матрица:') ;

    for i:=1 to n do

    begin

    for j:=1 to n do

    write (arr[i, j]:4) ;

    writeln () ;

    end;

    //Сортировка

    for j:=1 to n do

    for i:=1 to n-1 do

    for t:=i+1 to n do

    if arr[i, j] > arr[t, j] then

    begin

    buf : = arr[i, j];

    arr[i, j] : = arr[t, j];

    arr[t, j] : = buf;

    end;

    writeln ('Отсортированная матрица:') ;

    for i:=1 to n do

    begin

    for j:=1 to n do

    write (arr[i, j]:4) ;

    writeln () ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана матрица 4 на 4 упорядочить каждыйстолбц по возрастанию методом пузырька ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Задана матрица В (n, m). Определить количество столбцов, упорядоченных по возрастанию. Каждый второй столбец упорядочить по возрастанию и найти, на сколько увеличилось количество таких упорядоченных столбцов. (в паскале решить)
Ответы (1)
Дан массив b (n). Переписать в массив C (n) отрицательные элементы массива b (n) умноженные на 4. Затем упорядочить методом "пузырька" по возрастанию новый массив. Найти общее количество одинаковых элементов в упорядоченном массиве.
Ответы (1)
1. Дан массив х (n). Переписать в массив y (n) элементы массива х, большие 3. Затем упорядочить методом "пузырька" по возрастанию новый массив. Выдать на экран номера одинаковых элементов в упорядоченном массиве.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)