Задать вопрос
19 августа, 05:50

Задана матрица В (n, m). Определить количество столбцов, упорядоченных по возрастанию. Каждый второй столбец упорядочить по возрастанию и

найти, на сколько увеличилось количество таких упорядоченных

столбцов. (в паскале решить)

+1
Ответы (1)
  1. 19 августа, 06:43
    0
    Const

    n=5; m=10;

    var

    b:array[1 ... n, 1 ... m]of integer;

    i, j, k, buf, l:integer;

    begin

    for i:=1 to n do

    begin

    writeln;

    for j:=1 to m do

    begin

    b[i, j]:=random (50) ;

    write (b[i, j]:4) ;

    end;

    end;

    writeln;

    for j:=1 to m do

    begin

    k:=0;

    for i:=1 to n-1 do

    if b[i, j]
    k:=k+1;

    if k=n-1 then

    buf:=buf+1;

    end;

    k:=0;

    for l:=2 to m do

    if l mod 2=0 then

    for i:=1 to n-1 do

    for j:=i+1 to n do

    if b[i, l]>b[j, l]then

    begin

    k:=b[i, l];

    b[i, l]:=b[j, l];

    b[j, l]:=k;

    end;

    writeln ('увеличилось ', m div 2-buf) ;

    for i:=1 to n do

    begin

    writeln;

    for j:=1 to m do

    write (b[i, j]:4) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задана матрица В (n, m). Определить количество столбцов, упорядоченных по возрастанию. Каждый второй столбец упорядочить по возрастанию и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Упорядочить каждый столбец матрицы по возрастанию. Массив размером M*N, элементы которого задаются датчиком случайных чисел на интервале [-17; 26]. Программа выводит начальный вариант массива построчно, затем отсортированный массив построчно.
Ответы (1)
Дана прямоугольная матрица целых чисел размером N*M (N, M - вводим с клавиатуры). Вставить столбец из нулей после столбцов с минимальными элементами.
Ответы (1)