Задать вопрос
12 января, 16:00

Дан массив L, содержащий 40 элементов в интервале от 10 до 50, замените первый и последний элементы массива. Заранее буду благодарен, сделайте в паскале.

+4
Ответы (1)
  1. 12 января, 17:24
    0
    Var a : array[1 ... n] of integer;

    b, i : integer;

    begin

    Randomize;

    for i:=1 to n do

    begin

    a[i]:=random (41) + 10;

    write (a[i],' ') ;

    end;

    writeln;

    b:=a[1]; a[1]:=a[n]; a[n]:=b;

    for i:=1 to n do write (a[i],' ') ;

    writeln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив L, содержащий 40 элементов в интервале от 10 до 50, замените первый и последний элементы массива. Заранее буду благодарен, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)