Задать вопрос
21 октября, 13:31

В массиве [1 ... 30} замените все отрицательные числа на 5, а оставшиеся на 2.

Желательно сделать через цикл For и написать программу.

+2
Ответы (1)
  1. 21 октября, 16:25
    0
    Const n=30;

    var a:array[1 ... n] of integer;

    i:integer;

    begin

    Randomize;

    writeln ('Исходный массив:') ;

    for i:=1 to n do

    begin

    a[i]:=random (21) - 10;

    write (a[i]:4) ;

    end;

    writeln;

    writeln ('Измененный массив:') ;

    for i:=1 to n do

    if a[i]<0 then a[i]:=5 else a[i]:=2;

    for i:=1 to n do write (a[i]:4) ;

    writeln;

    end.

    Пример (для n=10) :

    Исходный массив:

    -2 6 - 4 7 - 4 4 - 9 5 2 1

    Измененный массив:

    5 2 5 2 5 2 5 2 2 2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве [1 ... 30} замените все отрицательные числа на 5, а оставшиеся на 2. Желательно сделать через цикл For и написать программу. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программы в Паскале: 1) цикл с предусловием. Написать программу, вычисления у=х2 при х=2, 4, 6, 8, 10; 2) цикл с постусловием.
Ответы (1)
В каком типе цикла тело цикла выполняется пока условие ложно? А) цикл со счетчиком Б) цикл с постусловием В) цикл с предусловием Г) цикл с рекурсией
Ответы (1)
Прошу, помогите написать программу! (Тема - Операции над массивами.) Написать программу, которая в одномерном массиве, заданным вводом данных с клавиатуры находит число положительных чисел в массиве.
Ответы (1)
2. В массиве Z[1 ... N] определить сумму нечетных чисел от последнего нулевого значения до Z[N] и среднее арифметическое четных чисел, находящихся в массиве до последнего нуля. Если нулей в массиве нет, то рассортировать все числа по убыванию.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)