Задать вопрос
7 марта, 11:07

1. Массив состоит из чисел 7, 8 и 9. Переставить элементы массива таким образом, чтобы сначала стояли все числа 8, потом - 7, а в конце - 9.

2. Написать программу, определяющую возможность представления заданного натурального числа М в виде суммы двух квадратов натуральных чисел.

+4
Ответы (1)
  1. 7 марта, 14:20
    0
    1) var ar:array[1 ... 10] of integer;

    ar2:array[1 ... 10] of integer;

    i, k, m:integer;

    begin;

    randomize;

    writeln ('First array') ;

    for i:=1 to 10 do

    begin;

    ar[i]:=random (7,9) ;

    write (ar[i]:4) ;

    end;

    m:=0;

    writeln;

    for i:=1 to 10 do

    if ar[i]=8 then

    begin;

    inc (m) ;

    ar2[m]:=8;

    end;

    for i:=1 to 10 do

    if ar[i]=7 then

    begin;

    inc (m) ;

    ar2[m]:=7;

    end;

    for i:=1 to 10 do

    if ar[i]=9 then

    begin;

    inc (m) ;

    ar2[m]:=9;

    end;

    writeln ('Final array') ;

    for i:=1 to 10 do

    begin;

    ar[i]:=ar2[i];

    write (ar[i]:4) ;

    end;

    end.

    2) var a, b, m, i, j, c:int64;

    begin;

    readln (m) ;

    for i:=1 to m do

    begin;

    for j:=1 to m do

    if sqr (i) + sqr (j) = m then

    begin;

    writeln (i,'^2+', j,'^2=', m) ;

    c:=1;

    end;

    end;

    if c1 then

    writeln ('Невозможно') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Массив состоит из чисел 7, 8 и 9. Переставить элементы массива таким образом, чтобы сначала стояли все числа 8, потом - 7, а в конце - ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сумма 2 квадратов написать программу определяющую возможность представления заданного натурального числа n в виде суммы двух квадратов натуральных чисел
Ответы (1)
Написать программу, определяющую возможность представления заданного натурального числа М в виде суммы двух квадратов натуральных чисел.
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)