Задать вопрос
23 февраля, 06:53

Написать программу, определяющую возможность представления заданного натурального числа М в виде суммы двух квадратов натуральных чисел.

+1
Ответы (1)
  1. 23 февраля, 07:54
    0
    Program rabota_01;

    var m, n: Longint;

    i, j: Integer;

    begin

    Write ('Введите M: ') ; ReadLn (m) ;

    for i:=Trunc (Sqrt (m)) downto 1 do begin

    n:=Sqr (i) ; j:=1; while (j<=i) and (n+Sqr (j)
    if n+Sqr (j) = m then begin

    WriteLn (m,' = ', i,'^2 + ', j,'^2') ; Exit;

    end;

    end;

    WriteLn (m,' не является суммой квадратов натуральных чисел.') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, определяющую возможность представления заданного натурального числа М в виде суммы двух квадратов натуральных чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сумма 2 квадратов написать программу определяющую возможность представления заданного натурального числа n в виде суммы двух квадратов натуральных чисел
Ответы (1)
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
1. Массив состоит из чисел 7, 8 и 9. Переставить элементы массива таким образом, чтобы сначала стояли все числа 8, потом - 7, а в конце - 9. 2.
Ответы (1)