Задать вопрос
3 июня, 09:24

Сумма 2 квадратов написать программу определяющую возможность представления заданного натурального числа n в виде суммы двух квадратов натуральных чисел

+1
Ответы (1)
  1. 3 июня, 11:33
    0
    Вот программа, если мы хотим сложить 2 квадрата одного числа

    program sqr;

    var n, a: integer;

    begin

    write ('Введите число>>') ;

    read (n) ;

    a: = n*n+n*n;

    writeln (a)

    end.

    Но если мы хотим выразить 1 число в виде суммы 2-х квадратов и проверить возможно ли это, то (боюсь ошибиться)

    program sqr;

    uses crt;

    var n: integer; a, b:real;

    begin

    write ('Введите число>>') ;

    read (n) ;

    a: = sqrt (n) ;

    if (a = sqrt (n)) and (a = (n*n)) then

    begin

    b: = sqrt (a) ;

    if b = (a*a) + (a*a) then

    writeln ('Можно') ;

    if b (a*a) + (a*a) then

    writeln ('Нельзя') ;

    end;

    if (a = sqrt (n)) and (an*n) then

    writeln ('Нельзя')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сумма 2 квадратов написать программу определяющую возможность представления заданного натурального числа n в виде суммы двух квадратов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, определяющую возможность представления заданного натурального числа М в виде суммы двух квадратов натуральных чисел.
Ответы (1)
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
1. Массив состоит из чисел 7, 8 и 9. Переставить элементы массива таким образом, чтобы сначала стояли все числа 8, потом - 7, а в конце - 9. 2.
Ответы (1)