Задать вопрос
18 мая, 05:26

Помогите написать программу на паскале абс

цикл с постусловием

Дано целое число N (> 1). Вывести наименьшее из целых чисел K, для которых сумма

1 + 2 + ... + K будет больше или равна N, и саму эту сумму.

+3
Ответы (1)
  1. 18 мая, 09:01
    0
    Var n, k, summ:integer;

    begin

    write ('Введи число N: ') ;

    readln (n) ;

    repeat begin

    k:=k+1;

    summ:=summ+k;

    end;

    until summ>=n;

    writeln ('K=', k,', 1 + ... + ', k,'=', summ,', ', summ,'>=', N) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу на паскале абс цикл с постусловием Дано целое число N (> 1). Вывести наименьшее из целых чисел K, для которых ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Напишите программы в Паскале: 1) цикл с предусловием. Написать программу, вычисления у=х2 при х=2, 4, 6, 8, 10; 2) цикл с постусловием.
Ответы (1)
В каком типе цикла тело цикла выполняется пока условие ложно? А) цикл со счетчиком Б) цикл с постусловием В) цикл с предусловием Г) цикл с рекурсией
Ответы (1)
Составить программу вычисления суммы всех целых чисел от 0 до 100. 1 использовать цикл с предусловием. 2 использовать цикл с постусловием. 3 использовать цикл с параметром
Ответы (1)
Составьте программу возведения в квадрат всех целых чисел от 0 до 50. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (2)