Задать вопрос
18 мая, 05:28

Нужно сформировать линейный массив по формуле, вывод должен быть в строку и столбик.

Найти количество элементов некратных 7.

Количество отрицательных элементов.

Удалить 3 элемент и вставить 99 на 5 место

+3
Ответы (1)
  1. 18 мая, 07:31
    0
    Const

    maxn = 100;

    type

    myarr = array [1 ... maxn] of longint;

    var

    a: myarr;

    i, n, k7, kotr: longint;

    begin

    writeln ('Введите количество элементов массива:') ;

    readln (n) ;

    for i : = 1 to n do begin

    a[i] : = random (100) ; / / i * i div a[i - 1];

    if (a[i] mod 7 = 0) then

    inc (k7) ;

    if (a[i] < 0) then

    inc (kotr) ;

    end;

    write (a[i], ' ') ;

    for i : = 3 to 5 do

    a[i] : = a[i + 1];

    a[5] : = 99;

    for i : = 1 to n do

    writeln (a[i]) ;

    end.

    И где, собственно, формула?
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно сформировать линейный массив по формуле, вывод должен быть в строку и столбик. Найти количество элементов некратных 7. Количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Написать и выполнить программу: сформировать массив из 15 целых чисел из [-28; 25], вывести исходный массив в строку; найти произведение всех элементов; найти количество положительных элементов; найти минимальный элемент и его индекс.
Ответы (1)
4. Из элементов массива A сформировать массив A той же размерности по правилам: Если номер четный, то B[i]:=i*, если нечетный, то B[i]:=-A[i]. 5. Сформировать массив а с помощью датчика случайных чисел целыми числами из интервала [-15,70]. 6.
Ответы (1)