Задать вопрос
7 июля, 13:24

Дан массив заданный случайным образом. Найти s и p элементов, кратных 3-ём и положительных, кол-во всех остальных.

+1
Ответы (1)
  1. 7 июля, 14:04
    0
    Const

    n=10;

    var a:array[1 ... n] of integer;

    s, p, k, i:integer;

    begin

    s:=0;

    p:=1;

    randomize;

    for i:=1 to n do begin

    a[i]:=Random (100) ;

    if (a[i]>0) and (a[i] mod 3 = 0) then k:=k+1;

    p:=p*a[i];

    s:=s+a[i];

    write (a[i], ' ')

    end;

    writeln ('Сумма = ', s) ;

    writeln ('Произведение = ', p) ;

    writeln ('Количество положительных и кратных 3-м = ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив заданный случайным образом. Найти s и p элементов, кратных 3-ём и положительных, кол-во всех остальных. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Дан одномерный целочисленный массив K из 15 элементов, заданный случайным образом в диапазоне от - 20, до + 25. Найдите сумму всех положительных элементов, индексы которых кратны 3. Вывести на экран сам массив и сумму.
Ответы (2)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)