Задать вопрос
23 августа, 21:08

Найти угол между отрезком прямой, соединяющий начало координат с точкой А (х, у) и осью ОХ. точка лежит в первой четверти

+5
Ответы (1)
  1. 23 августа, 23:45
    0
    Var

    x, y, f, eps:real;

    begin

    eps:=0.000000001;

    Readln (x, y) ;

    if x>eps then

    f:=arctan (y/x)

    else f:=3.1415926535/2;

    Writeln ('Угол = ', f:1:4, ' радиан = ', (f*180) / 3.1415926535:3:4, ' градусов') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти угол между отрезком прямой, соединяющий начало координат с точкой А (х, у) и осью ОХ. точка лежит в первой четверти ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача pascal Даны целочисленные координаты точки на плоскости. Если точка совпадает с началом координат, то вывести 0. Если точка не совпадает с началом координат, но лежит на оси ОХ или OY, то вывести соответственно 1 или 2.
Ответы (1)
Составьте программу, определяющую, лежит ли точка с указанными координатами X, Y на окружности радиуса R с центром в начале координат.
Ответы (1)
Помогите сделать в паскале! Запросить с клавиатуры координаты точки (X, Y) и горизонтального отрезка прямой (Xn, Xk, Yn) и определить, лежит точка на отрезке прямой или нет. Сообщение об этом вывести на экран. Подсказка.
Ответы (1)
На плоскости задана прямоугольная система координат, которая делит плоскость на 4 квадранта (четверти). Вводятся координаты (х, у). Определить какому квадранту (четверти) принадлежит точка.
Ответы (1)
Составить программу, определяющую, какой четверти декартовой системы координат принадлежит точка (x, y). На входе - координаты точки, на выходе - номер четверти. Выполнять в паскале Если точно не знаете, то не пишите
Ответы (1)