Задать вопрос
1 апреля, 21:40

Напишите программу, которая получает на вход 4 х-значное число и выдает суммы 1 ой и 4 ой цифр, а также 2 ой и 3 ей

+4
Ответы (1)
  1. 2 апреля, 01:15
    0
    Var a, a4, a3, a2, a1:integer;

    begin

    readln (a) ;

    a4:=a mod 10;

    a:=a div 10;

    a3:=a mod 10;

    a:=a div 10;

    a2:=a mod 10;

    a:=a div 10;

    a1:=a mod 10;

    writeln (a4+a1) ;

    write (a3+a2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая получает на вход 4 х-значное число и выдает суммы 1 ой и 4 ой цифр, а также 2 ой и 3 ей ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
Помогите сделать программу в Паскале В котором 1) Программа выдает сообщение "Вы маль или дево" 2) Пользователь в переменную ST1 задает значение маль или дево 3) Программа выдает сооб "Ты пошла бы играть в куклы" 4) Вводить ответ через переменную
Ответы (1)
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
Вход: 12 выход: 21; вход: школа выход: не могу; вход: 25 выход: 47; вход: 137 выход: 271. Какое правило?
Ответы (1)