Задать вопрос
21 апреля, 04:07

Дан массив из N целых чисел. Определить количество элементов масива значения которых больше 5

+1
Ответы (1)
  1. 21 апреля, 04:18
    0
    Const

    handsfree = true;

    var

    a: array[1 ... 100] of real;

    i, n: integer;

    min, max: real;

    k: integer;

    begin

    {ввод массива}

    if handsfree then

    n : = random (20) + 5

    else begin

    write ('n = ') ;

    readln (n) ;

    end;

    writeln ('Данные массива:') ;

    for i : = 1 to n do

    begin

    if handsfree then begin

    a[i] : = random (100) ;

    write (a[i], ' ') ;

    end

    else readln (a[i]) ;

    end;

    writeln () ;

    {подсчет элементов}

    k : = 0;

    for i : = 1 to n do

    if a[i] > 5 then k : = k + 1;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из N целых чисел. Определить количество элементов масива значения которых больше 5 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)