Задать вопрос
21 апреля, 01:51

Составить программу вычисление площади треугольника по трём сторонам. S=1/2aha

+5
Ответы (1)
  1. 21 апреля, 05:21
    0
    По трем сторонам - формула Герона.

    var a, b, c, p:real;

    begin

    write ('Введите стороны: ') ;

    readln (a, b, c) ;

    p : = (a + b + c) / 2;

    writeln ('Площадь равна ', sqrt (p * (p - a) * (p - b) * (p - c)) : 9:4) ;

    end.

    А через основание и высоту (твоя формула) :

    var a, h:real;

    begin

    write ('Введите длину основания и высоты, проведенной к нему: ') ;

    readln (a, h) ;

    writeln ('Площадь равна: ', (a * h) / 2:9:4) ;

    :9:4 - - это такой оператор, который выводит число в формате с фиксированной точкой и 4 знаками после запятой.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу вычисление площади треугольника по трём сторонам. S=1/2aha ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Укажите, что дано и что надо получить: а) вычисление стоимости покупок в магазине б) вычисление суммы сдачи от данных вами продавцу денег в) определение времени показа по телевизору интересующего вас фильма г) вычисление площади треугольника д)
Ответы (1)
Помогите! Написать программу вычисления площади треугольника, если известна длина основания и высота. Ниже представлен рекмндуемый вид экрана во время работы программы. Вычисление площади треугольника. Введите исходные данные: Основание (см) - 8.
Ответы (1)
Определите полный наборданных для решения следующих задач обработки информации: а) вычисление стоимости покупок в магазине б) вычисление суммы сдачи от данных Вами продавцу денег в) определение времени показа по телевизору интересующего Вас фильма
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)