Задать вопрос
11 января, 02:52

Нужно написать программу на PascalABC.

Вводится n чисел, найти максимальное двузначное среди них.

+1
Ответы (1)
  1. 11 января, 03:32
    0
    Var

    n, max, i, a : longint;

    begin

    readln (n) ; {количество чисел}

    max:=0; {чтобы вывести 0 если нет двухзначных}

    for i:=1 to n do

    begin

    readln (a) ; {хранить массив не надо т. к. он нигде не требуется}

    if (a>9) and (amax)

    then max:=a;

    end;

    if max>0

    then writeln (max)

    else writeln ('нет двухзначных чисел')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно написать программу на PascalABC. Вводится n чисел, найти максимальное двузначное среди них. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Помогите нужно использовать программу PascalABC Вариант 2 Программа PascalABC Кровяное давление у старшеклассников считается нормальным, если верхняя его граница H ≤ 100, а нижняя h ≥ 60 и H-h ≥ 30.
Ответы (1)
1. Вводится номер месяца. Надо определить к какому сезону относится этот месяц 2. Написать программу, которая грамотно печатает фразу "У меня К друзей". К вводится с клавиатуры.
Ответы (1)
Нужно подробное написание программы в pascalABC 1) С клавиатуры вводится число в интервале от 1 до 999. Написать программу, которая определяет количество цифр во введенном числе.
Ответы (1)
Нужно создать программу в pascalABC. Условие задачи: Вводится 3-ёх значное число, нужно найти сумму только чётных чисел, если их нет, то сообщить об этом.
Ответы (1)