Задать вопрос
23 марта, 11:02

Нужно создать программу в pascalABC. Условие задачи: Вводится 3-ёх значное число, нужно найти сумму только чётных чисел, если их нет, то сообщить об этом.

+1
Ответы (1)
  1. 23 марта, 12:52
    0
    Ввод: 123

    Вывод: 2

    var

    number, sum:integer;

    begin

    readln (number) ;

    sum : = 0;

    while (number 0) do begin

    if (number mod 10) mod 2 = 0 then

    sum : = sum + (number mod 10) ;

    number : = number div 10;

    end;

    if sum 0 then

    writeln (sum)

    else writeln ('Четных цифр в числе нет!') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно создать программу в pascalABC. Условие задачи: Вводится 3-ёх значное число, нужно найти сумму только чётных чисел, если их нет, то ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
Нужно написать программу на PascalABC Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)