Задать вопрос
22 сентября, 09:13

1. Вводится номер месяца. Надо определить к какому сезону относится этот месяц

2. Написать программу, которая грамотно печатает фразу "У меня К друзей". К вводится с клавиатуры. Например, для К=1 должно напечататься " У меня 1 друг", для К=24 - "У меня 24 друга", для К=100 - "У меня 100 друзей".

Написать программу в PascalABC

+3
Ответы (1)
  1. 22 сентября, 09:43
    0
    1)

    var x:integer;

    begin

    read (x) ;

    if (x=12) or (x=1) or (x=2) then writeln ('Зима') ;

    if (x=3) or (x=4) or (x=5) then writeln ('Весна') ;

    if (x=6) or (x=7) or (x=8) then writeln ('Лето') ;

    if (x=9) or (x=10) or (x=11) then writeln ('Осень') ;

    end.

    2)

    var K, a:integer;

    begin

    readln (K) ;

    a:=K mod 10;

    if (K=11) or (K=12) or (K=13) or (K=14) then writeln ('У меня ', K,' друзей') else

    begin

    if (a=1) then writeln ('У меня ', K,' друг') ;

    if (a=0) or ((a>=5) and (a<=9)) then writeln ('У меня ', K,' друзей') ;

    if (a>=2) and (a<=4) then writeln ('У меня ', K,' друга') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Вводится номер месяца. Надо определить к какому сезону относится этот месяц 2. Написать программу, которая грамотно печатает фразу "У ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, которая грамотно печатает фразу "У меня К друзей". К вводится с клавиатуры. Например, для К=1 должно напечататься " У меня 1 друг", для К=24 - "У меня 24 друга", для К=100 - "У меня 100 друзей". написать программу в paskal
Ответы (1)
Всё сделать в программе PascalABC Задача №1 С клавиатуры вводится число n. Заполнить n элементов массива числами 2,4,8,16 ... и вывести массив. В массиве может находить не более 100 элементов. Задача №2 С клавиатуры вводится число n.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Задание 1. Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе. Пример: Введите номер месяца: -2 Введите номер месяца: 11 В этом месяце 30 дней. Вы вводили неверно 1 раз. Задание 2.
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)