Задать вопрос
24 июня, 07:32

Помогите в Pascal

№4. Дана величина A, выражающая объем информации в мегабайтах. Составьте программу перевода величины А в более мелкие единицы информации.

№5. Даны длины сторон треугольника A, B, C. Найти площадь треугольника S. Составьте программу решения поставленной задачи.

, где р - полупериметр

№6. Для заданного количества суток (tfh) требуется определить количество часов (h), минут (m) и секунд (c).

+1
Ответы (1)
  1. 24 июня, 09:54
    -1
    4.

    var

    a:real;

    begin

    write ('Введите количество мегабайт=') ; read (a) ;

    writeln ('Количество килобайт=', a*1024) ;

    writeln ('Количество байт=', a*1024*1024) ;

    writeln ('Количество бит=', a*1024*1024*8) ;

    end.

    5.

    var

    a, b, c, p, S:real;

    begin

    write ('Введите сторону a=') ; read (a) ;

    write ('Введите сторону b=') ; read (b) ;

    write ('Введите сторону c=') ; read (c) ;

    P: = (a+b+c) / 2;

    S:=sqrt (p * (p-a) * (p-b) * (p-c)) ;

    write ('S=', s:5:2) ;

    end.

    6.

    var

    a:integer;

    begin

    write ('Введите количество суток=') ; read (a) ;

    writeln (24*a,' ','часов') ;

    writeln (60*24*a,' ','минут') ;

    writeln (60*60*24*a,' ','секунд') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите в Pascal №4. Дана величина A, выражающая объем информации в мегабайтах. Составьте программу перевода величины А в более мелкие ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для заданного количества суток (tfh) требуется определить количество часов (h), минут (m) и секунд (с)
Ответы (1)
Для заданного количества суток (tfh) требуется определить количество часов (h), минут (m) и секунд (с) (на рус)
Ответы (1)
Идет i-ая секунда суток. Напишите программу, которая по введенной i-ой секунде суток определит, сколько целых часов h, целых минут min и секунд с прошло с начала суток. Например: 13257 секунд = 3 часа 40 минут и 57 секунд.
Ответы (1)
Задана последовательность из n вещественных чисел. Определить сумму и количество элементов последовательности, меньших заданного значения d. Задание: Средствами языка Pascal напишите программу для решения поставленной задачи.
Ответы (1)
Написать программу к следующей задаче: Вводится с клавиатуры число, которое обозначает количество суток. Написать программу расчета количества часов, количества минут и количества секунд по заданному количеству суток.
Ответы (1)