Задать вопрос
20 июня, 18:00

Найдите произведение цифр заданного k-значного числа)

+5
Ответы (1)
  1. 20 июня, 21:12
    0
    Var

    k, s: integer;

    begin

    readln (k) ;

    s:=1;

    while k > 0 do

    begin

    s : = s * (k mod 10) ;

    k : = k div 10;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найдите произведение цифр заданного k-значного числа) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Да ну трёх значные числа. Напишите программу, который определяет: А) Есть ли среди цифр заданного целого трёх значного числа одинаковый 123 нет 121 да 222 да Б) Является ли число перевертышем то есть число десятичной записи которые читаются
Ответы (1)
Является ли сумма цифр заданного 4-значного числа, стоящих в разрядах сотен и десятков (например, 4 567) числом, кратным 3 или 2?
Ответы (1)