Задать вопрос
11 марта, 05:01

Даны координаты трех вершин треугольника : (Х1, у1), (х2, у2), (х3, у3). найти его периметр и площадь, используя формулу для расстояния между двумя точками на плоскости. Для нахождения площади треугольника со сторонами а, b, с использовать формулу Герона:

S = (p * (p-a) * (p-b) * (p-c)) 12, где p = (a+b+c) / 2--полупериметр

+2
Ответы (1)
  1. 11 марта, 05:24
    -1
    Var

    x1, y1, x2, y2, x3, y3, a, b, c, p, s:real;

    begin;

    readln (x1) ;

    readln (y1) ;

    readln (x2) ;

    readln (y2) ;

    readln (x3) ;

    readln (y3) ;

    a:=sqrt (sqr (x2-x1) + sqr (y2-y1)) ;

    b:=sqrt (sqr (x3-x2) + sqr (y3-y2)) ;

    c:=sqrt (sqr (x3-x1) + sqr (y3-y1)) ;

    p:=a+b+c;

    s:=sqrt (p/2 * (p/2-a) * (p/2-b) * (p/2-c)) ;

    writeln ('P=', p) ;

    writeln ('S=', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны координаты трех вершин треугольника : (Х1, у1), (х2, у2), (х3, у3). найти его периметр и площадь, используя формулу для расстояния ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задачу решить двумя способами: с использованием подпрограммы-функции и подпрограммы-процедуры. Обязательно построение блок-схем алгоритмов! 1. Треугольник задан координатами своих вершин.
Ответы (1)
Прямоугольник. Зная координаты трех вершин прямоугольника на координатной плоскости, определить координаты четвертой вершины. Входные данные В одной строке записаны шесть чисел - координаты трех вершин прямоугольника.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Составе программу нахождения площади треугольника по известным сторонам. Используйте формулу Герона S=√p (p-a) (p-в) (p-c) a+в+с/2
Ответы (1)
Даны координаты трех вершин треугольника. Найти его площадь. Пример. Для вершин (0.0) ; (0,1) ; (1,0) площадь - 0,5.
Ответы (1)