Задать вопрос
3 декабря, 08:11

Составе программу нахождения площади треугольника по известным сторонам. Используйте формулу Герона

S=√p (p-a) (p-в) (p-c)

a+в+с/2

+2
Ответы (1)
  1. 3 декабря, 09:18
    0
    На каком языке надо написать?

    На Паскале:

    program geron;

    var a, b, c, p: Real;

    begin

    ReadLn (a, b, c) ;

    p : = (a+b+c) / 2;

    WriteLn ('S = ', sqrt (p * (p-a) * (p-b) * (p-c))) ;

    end.

    На С++

    #include

    #include

    void main ()

    {

    double a, b, c, p;

    std::cin >> a >> b >> c;

    p = (a+b+c) / 2;

    std::cout << "S = " << sqrt (p * (p-a) * (p-b) * (p-c)) << std::endl;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составе программу нахождения площади треугольника по известным сторонам. Используйте формулу Герона S=√p (p-a) (p-в) (p-c) a+в+с/2 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Задача по теме "Линейный алгоритм". Pascal ABC Найти площадь треугольника по известным трем сторонам (по формуле Герона).
Ответы (2)
1. Составить программу для нахождения площади трапеции. 2. Составить программу для нахождения квадрата суммы двух чисел (по формулам сокращённого умножения). 3.
Ответы (1)
1. Переведите известным вам способом число 12 в двоичную систему счисления. 2. Переведите известным вам способом число 0,375. в двоичную систему счисления 3. Переведите известным вам способом число 12,375 в двоичную систему счисления.
Ответы (1)
Составить программу для вычесления площади и периметра треугольника (известны все три стороны) при двух условиях: если треугольник прямоугольный и если нет, то через формулу герона. В Паскале нужна программа
Ответы (1)