Задать вопрос
21 декабря, 13:46

Составить программу для вычесления площади и периметра треугольника (известны все три стороны) при двух условиях: если треугольник прямоугольный и если нет, то через формулу герона. В Паскале нужна программа

+2
Ответы (1)
  1. 21 декабря, 15:53
    0
    Program zadanie;

    var a, b, c, s, p, pp:real;

    begin

    writeln ('Введите сторону a') ;

    read (a) ;

    writeln ('Введите сторону b') ;

    read (b) ;

    writeln ('Введите сторону c') ;

    read (c) ;

    p:=a+b+c;

    pp:=p/2;

    if (sqr (a) = sqr (b) + sqr (c)) then

    begin

    writeln ('Прямоугольный треугольник с гипотенузой a') ;

    s:=1/2*b*c;

    writeln ('Площадь = ', s) ;

    end;

    if (sqr (b) = sqr (a) + sqr (c)) then

    begin

    writeln ('Прямоугольный треугольник с гипотенузой b') ;

    s:=1/2*a*c;

    writeln ('Площадь = ', s) ;

    end;

    if (sqr (c) = sqr (b) + sqr (a)) then

    begin

    writeln ('Прямоугольный треугольник с гипотенузой c') ;

    s:=1/2*b*a;

    writeln ('Площадь = ', s) ;

    end

    else

    begin

    writeln ('Непрямоугольный треугольник') ;

    s:=sqrt (pp * (pp-a) * (pp-b) * (pp-c)) ;

    writeln ('Площадь = ', s) ;

    end;

    writeln ('Периметр = ', p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу для вычесления площади и периметра треугольника (известны все три стороны) при двух условиях: если треугольник ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите сделать программу в Паскале В котором 1) Программа выдает сообщение "Вы маль или дево" 2) Пользователь в переменную ST1 задает значение маль или дево 3) Программа выдает сооб "Ты пошла бы играть в куклы" 4) Вводить ответ через переменную
Ответы (1)
Зачетная работа по информатике. 1. Написать программу вычисления площади прямоугольника (на паскале). 2. Написать программу вычесления ускорения тела (на паскале).
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Известны длины сторон треугольника a, b, c. Написать программу, вычисляющую площадь этого треугольника (по формуле Герона). Выполнить программу для исходных данных a=3, b=4, c=5. Язык Паскаль.
Ответы (1)
Составить словесный алгоритм и блок-схему нахождения площади треугольника по формуле Герона, если известны все три стороны
Ответы (1)