Задать вопрос
3 января, 18:27

Уровень C. Введите массив с клавиатуры и найдите (за один проход) количество элементов, имеющих максимальное значение.

Пример:

Массив:

3 4 5 5 3 4 5

Максимальное значение 5

Количество элементов 3

+1
Ответы (1)
  1. 3 января, 20:09
    0
    Var

    mas: array[1 ... 7] of integer;

    k, i, MAX:integer;

    Begin

    for i:=1 to 7 do

    Begin

    writeln ('Введите число') ;

    readln (mas[i]) ;

    end;

    MAX:=mas[1];

    k:=1;

    for i:=2 to 7 do

    Begin

    if mas[i] > MAX

    then

    Begin

    MAX:=mas[i];

    k:=1;

    end

    else

    if MAX=mas[i]

    then k:=k+1;

    end;

    writeln () ;

    writeln ('Максимальное значение = ', MAX) ;

    writeln ('Количество элементов = ', k) ;

    readln () ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Уровень C. Введите массив с клавиатуры и найдите (за один проход) количество элементов, имеющих максимальное значение. Пример: Массив: 3 4 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
заполнить массив с клавиатуры и найти (за один проход) количество элементов имеющих максимальное значение
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)