Задать вопрос
3 января, 17:09

Сколько четырехзначных чисел, у которых сумма первой и третьей цифр равны сумме второй и четвертой. Напишите программу, которая позволит вывести все такие числа.

в паскале

+2
Ответы (1)
  1. 3 января, 19:40
    0
    Var a, b, c, d, e:integer;

    begin

    for a:=1000 to 9999 do begin

    e:=a;

    b: = e mod 10;

    e: = e div 10;

    c: = e mod 10;

    e: = e div 10;

    d: = e mod 10;

    e: = e div 10;

    if (b+d) = (c+e) then writeln (a) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сколько четырехзначных чисел, у которых сумма первой и третьей цифр равны сумме второй и четвертой. Напишите программу, которая позволит ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
Напишите на паскале (АВС). Задание: Среди всех четырехзначных натуральных чисел вывести на экран "особо счастливые", у которых сумма цифр в четных разрядах равна сумме цифр в нечетных.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)