Задать вопрос
16 января, 07:46

Написать программу которая для введённого пятизначного числа выводит количество нулей в нем

+2
Ответы (2)
  1. 16 января, 08:16
    0
    var

    n: integer;

    begin

    read (n) ;

    write (ord (n mod 10 = 0) + ord (n div 10 mod 10 = 0) + ord (n div 100 mod 10 = 0) + ord (n div 1000 mod 10 = 0)) ;

    end.
  2. 16 января, 09:44
    0
    Вот уже писал.

    uses crt;

    var a, n, i:integer;

    begin clrscr;

    write ('Vvedite chislo: ') ;

    read (a) ; n:=0;

    while a0 do begin

    if a mod 10=0 then inc (n) ;

    a:=a div 10;

    end;

    writeln ('N=', n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу которая для введённого пятизначного числа выводит количество нулей в нем ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Требовалось написать программу, которая для введённого натурального числа n выводит общее количество его различных делителей, включая 1 и n.
Ответы (1)