Задать вопрос
30 апреля, 01:55

Сформировать массив, подсчитать количество элементов не превосходящих заданного числа n-задано с клавиатуры. Найти их среднее арифметическое значение.

+5
Ответы (1)
  1. 30 апреля, 03:48
    0
    Var a:array [1 ... 20] of integer;

    s, k, i:integer;

    begin

    k:=0; s:=0;

    for i:=1 to n do

    read (a[i]) ;

    readln (n) ;

    for i:=1 to 20 do

    if a[i]<=n then begin

    k:=k+1;

    s:=s+a[i];

    end;

    writeln ('Кол-во:', k) ;

    writeln ('Средн. арифм.:', s/k)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сформировать массив, подсчитать количество элементов не превосходящих заданного числа n-задано с клавиатуры. Найти их среднее ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Помогите решить через паскаль 1) массив А вводится с клавиатуры, найти среднее арифметическое его элементов с нечетными номерами, размер произвольный.
Ответы (1)
1) задан массив из N элементов. вычислить среднее арифметическое тех элементов, которые кратны 3. 2) Задан массив из N элементов. Сформировать новый массив из элементов, кратных 7.
Ответы (1)
Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)