Задать вопрос
9 апреля, 20:58

Дана строка, состоящая из 50 символов. Составьте программу, используя процедуру которая определяет сколько раз встречается в строке слог 'ea'.

+2
Ответы (1)
  1. 10 апреля, 00:12
    0
    Var s:string; k:integer;

    procedure SubInc (var s:string; var k:integer) ;

    begin;

    while pos ('ea', s) 0 do

    begin;

    delete (s, pos ('ea', s),2) ;

    inc (k) ;

    end;

    end;

    begin;

    readln (s) ;

    if length (s) 10 then exit;

    SubInc (s, k) ;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана строка, состоящая из 50 символов. Составьте программу, используя процедуру которая определяет сколько раз встречается в строке слог ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)
Дана строка S, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в S ровно один раз. Формат входных данных Во входном файле дана строка S.
Ответы (1)
Дана строка текста, состоящая из слов. Слова отделяются друг от друга одним из специальных символов, которые описываются во множестве ['-', '*', '/', ',']. Подсчитайте количество разделителей в строке. в паскале. строка дана любая
Ответы (1)