Задать вопрос
24 июля, 07:56

Задано число. Определить, какие цифры не входят в это число. Решить в Паскале с помощью множеств.

+3
Ответы (1)
  1. 24 июля, 11:56
    0
    Var a, i:integer; mn:set of 0 ... 9;

    begin

    write ('a = ') ; readln (a) ;

    mn:=[];

    while a>0 do

    begin

    mn:=mn+[a mod 10];

    a:=a div 10;

    end;

    writeln ('В числе нет следующих цифр:') ;

    for i:=0 to 9 do

    if not (i in mn) then write (i:2) ;

    writeln;

    end.

    Пример:

    a = 1356

    В числе нет следующих цифр:

    0 2 4 7 8 9
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задано число. Определить, какие цифры не входят в это число. Решить в Паскале с помощью множеств. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На паскале нужно решить задачи 1. Задано трехзначное число. Составьте программу, с помощью которой определите произведение кубов цифр этого числа. 2. Задано трехзначное число.
Ответы (1)
Составить программу: 1. Задано пятизначное число. Выделить цифры, стоящие в разряде единиц и разряде тысяч. Вывести их в порядке убывания 2. Задано четырехзначное число. Удалить из записи числа последнюю цифру.
Ответы (1)
отношение между элементами множеств x и y задано уравнением у=х+1. Изобразите это отношение с помощью графа, если X = (3,6,9,12), Y = (7,10,13)
Ответы (1)
Решить в паскале задачу (8-9 класс) : дано четырехзначное число. определить, входят ли в него цифры 2 или 7
Ответы (1)
Напишите программы для решения задач. Используйте операция div и mod. 1. Задано двузначное число. Найдите среднее арифметическое цифр числа. 2. Задано двузначное число. Найдите разность между количеством десятков и единиц.
Ответы (2)