Задать вопрос
9 ноября, 13:40

Написать на Паскале

Остаток

Входные данные

Вводятся 4 числа: a, b, c и d.

Выходные данные

Выведите все числа на отрезке от a до b, дающие остаток c при делении на d. Если таких чисел не существует, то ничего выводить не нужно.

Примеры

входные данные

2

5

0

2

выходные данные

2 4

входные данные

2

7

9

14

+2
Ответы (1)
  1. 9 ноября, 14:47
    0
    Var

    a, b, c, d, i:integer;

    begin

    writeln ('Ввежите значения для a, b, c, d,') ;

    readln (a, b, c, d) ;

    writeln ('Результат') ;

    for i:=a to b do

    if (i mod d) = c then write (i,' ') ;

    writeln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать на Паскале Остаток Входные данные Вводятся 4 числа: a, b, c и d. Выходные данные Выведите все числа на отрезке от a до b, дающие ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Задача №334. Остаток Входные данные Вводятся 4 числа: a, b, c и d. Выходные данные Выведите все числа на отрезке от a до b, дающие остаток c при делении на d. Если таких чисел не существует, то ничего выводить не нужно.
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Написать на Паскале Четные числа Входные данные Вводятся целые числа a и b. Гарантируется, что a не превосходит b Выходные данные Выведите (через пробел) все четные числа от a до b (включительно). входные данные 2 5 выходные данные 2 4
Ответы (1)