Задать вопрос
23 мая, 13:05

Создать программу в ABC Pascal (с помощью строк сделать) :

Ввести строку состоящюю из различных символов и определить:

1) произведение цифр входяящих в эту строку (произведение может быть большим) ж

2) сумму цифр входящих в эту строку, если эти велечины есть

+4
Ответы (1)
  1. 23 мая, 14:27
    0
    Program str;

    Uses crt;

    Var s:string;

    i, p, sum:integer;

    Begin

    P:=1;

    Sum:=0;

    Readln (s) ;

    For i:=1 to length (s) do

    Begin

    If s[i] in ['0' ... '9'] then

    Begin

    p:=p * (ord (s[i]) - ord ('0')) ; sum:=sum + (ord (s[i]) - ord ('0')) ;

    End;

    End;

    Writeln ('Сумма = ', sum,' ','Произведение = ', p) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Создать программу в ABC Pascal (с помощью строк сделать) : Ввести строку состоящюю из различных символов и определить: 1) произведение цифр ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
1) Сколько символов в тексте, если 1) Сколько символов в тексте, если мощность алфавита-64 символа, а объем информации, содержащийся в нем-1,5 Кбайт. 2) Сообщение занимает 3 страницы по 25 строк. В каждой строке записано по 60 символов.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Приветствие участникам олимпиады от лунных человечков записано с помощью всех символов лунного алфавита: ЮМА_ЮМ. Сколько информации оно несет? 2. Сообщение занимает 6 страниц по 35 строк. В каждой строке записано по 50 символов.
Ответы (2)