Задать вопрос
23 февраля, 08:31

Квадрат заданного трехзначного числа равен кубу суммы цифр этого числа. Free pascal

+5
Ответы (1)
  1. 23 февраля, 08:41
    0
    Var a, s, d, ed, ost: integer;

    begin

    a:=99;

    repeat

    a:=a+1;

    s: = a div 100;

    ost: = a mod 100;

    if ost>9 then

    begin

    d: = ost div 10;

    ost:=ost mod 10;

    end else d: = 0;

    if ost<10 then ed:=ost;

    until (a<1000) and (a*a = ((s+d+ed) * (s+d+ed) * (s+d+ed))) ;

    writeln ('это число: ', a:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Квадрат заданного трехзначного числа равен кубу суммы цифр этого числа. Free pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия: - квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;
Ответы (1)
Определить, равен ли квадрат заданного трехзначного числа кубу суммы цифр этого числа в паскале
Ответы (1)
Помогите составить программу печатающую значение true и false Квадрат заданного трехзначного числа равен Кубу суммы цифр этого числа
Ответы (1)
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)