Задать вопрос
28 февраля, 08:09

Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

- квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

-точка с координатами (x, y) принадлежит части плоскости, лежащей между прямыми x=m, x=n (m

+1
Ответы (1)
  1. 28 февраля, 08:24
    0
    var b: 100 ... 999;

    s: word;

    x, y, m, n: integer;

    begin

    writeln ('Введите трехзначное число') ;

    readln (b) ;

    s: = (b mod 10) + ((b mod 100) div 10) + (b div 100) ; / / сумма цифр трехзначного числа

    if sqr (b) = sqr (s) * s then writeln ('True')

    else writeln ('False') ;

    writeln ('Введите координаты х и у') ;

    readln (x, y) ;

    writeln ('Введите m и n') ;

    readln (m, n) ;

    if (x>m) and (x
    else writeln ('False') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия: - квадрат заданного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы