Задать вопрос
20 февраля, 19:50

Напишите программу, которая выводит на экран все цифры числа начиная с первой. (на Паскале)

+5
Ответы (1)
  1. 20 февраля, 23:43
    0
    Var str, i, m:integer;

    n: string;

    a: array[1 ... 10] of integer;

    begin

    write ('Введите число: ') ;

    readln (str) ;

    if str < 0 then str : = - str; / / удаляем знак числа

    n : = IntToStr (str) ; / / преобразуем число в массив

    m : = length (n) ; / / считаем элементы массива

    for i : = 1 to m do writeln (n[i]) ; / / выводим элементы (цифры) числа

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая выводит на экран все цифры числа начиная с первой. (на Паскале) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
С++ Напишите программу, которая выводит на экран все цифры числа, начиная с первой. Допустим, вводишь 123, а программа выводит 1 2 3.
Ответы (1)
Помогите по программе paskal: 1. дано целое число. напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора результат 2. дано целое число.
Ответы (1)
Написать программу, которая выводит на экран результаты следующих действий: 27-5= 11+21= 32/2= 2+2*2= (2+2) * 2= Написать программу, которая выводит на экран результаты следующих действий: 21-4= 21+11= 43/3= 3+3*3= (3+3) * 3=
Ответы (1)