Задать вопрос
15 декабря, 13:23

С++

Напишите программу, которая выводит на экран все цифры числа, начиная с первой.

Допустим, вводишь 123, а программа выводит 1 2 3.

+4
Ответы (1)
  1. 15 декабря, 14:09
    0
    Один из простых методов.

    #include

    void digits (const unsigned &val)

    {

    if (val) {

    std::cout << (digits (val / 10), val % 10) << " ";

    }

    }

    int main ()

    {

    digits (123) ;

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С++ Напишите программу, которая выводит на экран все цифры числа, начиная с первой. Допустим, вводишь 123, а программа выводит 1 2 3. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами.
Ответы (1)
Программа спрашивает стороны прямоугольника, находим площадь и выводим на экран результат. Далее программа спрашивает любое число если число делиться на 5 выводит на экран сообщение число кратно 5 иначе выводит сообщение число не кратно 5 далее
Ответы (1)
Написать программы на языке С++ 1) С клавиатуры вводится 2 числа - целое и вещественное. Программа выводит их сумму на экран.
Ответы (1)