Задать вопрос
19 февраля, 00:28

Написать программу решения задачи: С клавиатуры вводят 9 вещественных чисел. Занести в типизированный файл только отрицательные из введённых чисел. При форматирование файла учесть, что в файле данные должны быть записаны в строку.

+5
Ответы (1)
  1. 19 февраля, 02:33
    0
    Var

    i:integer;

    n:real;

    f:file of real;

    begin

    Assign (f,'in. dat') ;

    Rewrite (f) ;

    Writeln ('Введите 9 вещественных чисел') ;

    for i:=1 to 9 do begin Read (n) ; Write (f, n) end;

    Close (f)

    end.

    Пример ввода:

    Введите 9 вещественных чисел

    2 - 5 1.45 - 81.34 5.63e-10 0 - 13.45e12 17.5353 - 12e-3 1000
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу решения задачи: С клавиатуры вводят 9 вещественных чисел. Занести в типизированный файл только отрицательные из ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) что можно узнать о файле по его имени из каких частей состоит имя файла 2) файл имеет только имя? 3) имя файла может быть написано буквами или цифрами.
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Дан символьный файл f. Записать в файле g, с сохранением порядка их следования, те символьные данные: a) которым в файле f предшествует буква а б) в след за которыми в файле f идёт буква а
Ответы (1)