Задать вопрос
18 июня, 18:49

Строка содержит одно слово-шалаш. Проверить будет ли оно читаться одинаково справа налево и слева направо.

+5
Ответы (1)
  1. 18 июня, 21:32
    0
    Var s : string;

    b : boolean;

    i, len : integer; begin readln (s) ; len : = length (s) ; b : = true; for i : = 1 to len div 2 do if s[i] s[len - i + 1] then begin b : = false; break; end; writeln (b) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Строка содержит одно слово-шалаш. Проверить будет ли оно читаться одинаково справа налево и слева направо. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
При выполнении какого из перечисленных ниже алгоритмов на экране появился правильный треугольник? 1 Повтори 3 [Вперёд 50 Направо 20 Направо 25] 2 Повтори 3 [Вперёд 50 Направо 100 Направо 20] 3 Повтори 6 [Вперёд 50 Направо 10 Направо 20] 4 Повтори 6
Ответы (1)
Слово называется палиндромом, если оно читается одинаково, как слева направо, так и справа налево. Требуется определить, какое минимальное количество букв надо добавить к входному слову справа, чтобы оно стало палиндромом.
Ответы (1)
Строка является палиндромом, если слева направо и справа налево она читается одинаково, например "кабак", "боб", "asdfggf' dsa". Составьте алгоритм и напишите программу, определяющую, является ли строка палиндромом.
Ответы (1)
Написать программу на языке Pascal Палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево.
Ответы (1)