Задать вопрос
25 сентября, 02:40

Цикл со счетчиком. Представить блок-схему и программу.

Дано два целых положительных числа a и n, вводимых с клавиатуры. Найти n^a.

+1
Ответы (1)
  1. 25 сентября, 03:41
    0
    var a, n, rez, i: integer;

    begin

    write ('Введите a: ') ;

    readln (a) ;

    write ('Введите n: ') ;

    readln (n) ;

    if a = 0 then rez : = 1

    else begin

    rez : = n;

    for i : = 1 to y - 1 do rez : = rez * n;

    end;

    writeln (rez) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Цикл со счетчиком. Представить блок-схему и программу. Дано два целых положительных числа a и n, вводимых с клавиатуры. Найти n^a. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
В каком типе цикла тело цикла выполняется пока условие ложно? А) цикл со счетчиком Б) цикл с постусловием В) цикл с предусловием Г) цикл с рекурсией
Ответы (1)
Составить программу в Pascal, используя цикл с счетчиком for 1. Напечатать квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b>10) 2. Напечатать все целые числа от a до b (значения a и b вводятся с клавиатуры)
Ответы (1)
на языке программирования Паскаль составить программу суммы нахождения суммы вводимых с клавиатуры положительных чисел. Печать результата по вводу 0 (используя цикл while т. е. предусловие).
Ответы (1)
1) Найдите сумму натуральных нечетных чисел не превышающих n! Это нужно сделать циклом for. 2) Составьте программу, которая производит суммирование произвольного количества целых чисел вводимых с клавиатуры.
Ответы (1)