Задать вопрос
5 августа, 14:22

3. Написать программу вычисления xy, не используя функцию возведения в степень (только цикл). X, y вводятся с клавиатуры

+5
Ответы (2)
  1. 5 августа, 14:38
    0
    Тривиальное решение.

    var

    i, r, x, y:integer;

    begin

    Write ('Вычисление х в степени y, введите х, y: ') ;

    Readln (x, y) ;

    r:=x;

    for i:=2 to y do r:=r*x;

    Writeln ('Результат: ', r)

    end.

    Тестовый прогон:

    Вычисление х в степени y, введите х, y: 2 10

    Результат: 1024

    Вариант для любителей начинать циклы с единицы.

    var

    i, r, x, y:integer;

    begin

    Write ('Вычисление х в степени y, введите х, y: ') ;

    Readln (x, y) ;

    r:=1;

    for i:=1 to y do r:=r*x;

    Writeln ('Результат: ', r)

    end.
  2. 5 августа, 14:41
    0
    Var x, y, p:integer;

    begin

    read (x, y) ;

    p:=x;

    for y:=y downto 2 do

    p*=x;

    writeln (p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «3. Написать программу вычисления xy, не используя функцию возведения в степень (только цикл). X, y вводятся с клавиатуры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
Составьте программу возведения в квадрат всех целых чисел от 0 до 50. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (2)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
Напишите программы в Паскале: 1) цикл с предусловием. Написать программу, вычисления у=х2 при х=2, 4, 6, 8, 10; 2) цикл с постусловием.
Ответы (1)