Задать вопрос
12 августа, 22:12

Написать программу перевода целого двоичного десятиразрядного числа в десятичную систему

+4
Ответы (1)
  1. 13 августа, 01:56
    0
    {

    Перевод двоичного числа в десятичное.

    Символы, отличающиеся от 0 и 1, заменяются нулями.

    Программа будет работать некорректно при вводе

    более 31 знака.

    }

    var

    bin:string;

    i, d:integer;

    p, dec:longint;

    begin

    Write ('Введите двоичное число: ') ; Read (bin) ;

    dec:=0;

    p:=1;

    for i:=Length (bin) downto 1 do

    begin

    if bin[i]='1' then d:=1 else d:=0;

    dec:=dec+d*p; p:=2*p

    end;

    Writeln ('Десятичный эквивалент: ', dec)

    end.

    Тестовое решение:

    Введите двоичное число: 1011011001

    Десятичный эквивалент: 729
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу перевода целого двоичного десятиразрядного числа в десятичную систему ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Правило перевода натуральных двоичных чисел в десятичную систему счисления: А) вывести восьмеричную систему в шестнадцатеричную, далее подвести к соответствующим единицам в свёрнутой форме записи двоичного числа Б) обязательно вычислить сумму
Ответы (1)
Напишите линейную программу перевода любого целого четырехзначного двоичного числа в десятичную систему счисления.
Ответы (1)
Вам нужно дать определение двоичного кодирования информации. Объсните универсальность двоичного кодирования. Назвать единицы измерения информании и объяснить правила перевода из одних единиц измерения в другие.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
1) Три десятичных числа (100,102,91) перевести в восьмеричную систему вычислить их сумму и перевести в десятичную систему вычислить их сумму и перевести в десятичную.
Ответы (1)