Задать вопрос
6 декабря, 10:40

Напишите линейную программу перевода любого целого четырехзначного двоичного числа в десятичную систему счисления.

+5
Ответы (1)
  1. 6 декабря, 11:01
    0
    Var i, input: integer;

    output: real;

    temp_str: string;

    begin

    write ('Введите четырехзначное двоичное число: ') ; readln (input) ;

    temp_str : = IntToStr (input) ;

    for i : = 1 to 4 do output : = output + (StrToInt (temp_str[i]) * exp (ln (2) * (4-i))) ; writeln (input, ' в десятичной: ', output) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите линейную программу перевода любого целого четырехзначного двоичного числа в десятичную систему счисления. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Правило перевода натуральных двоичных чисел в десятичную систему счисления: А) вывести восьмеричную систему в шестнадцатеричную, далее подвести к соответствующим единицам в свёрнутой форме записи двоичного числа Б) обязательно вычислить сумму
Ответы (1)
1.11010101,00011 переведите число из двоичной в десятичную систему счисления 2.10111101,110111 переведите число из двоичной в восьмиричную систему счисления 3.101100010100,1011 переведите число из двоичной в шестнадцатиричную систему счисления 4.
Ответы (1)
Написать программу перевода целого двоичного десятиразрядного числа в десятичную систему
Ответы (1)
А) 1000001110 в двоичной системе счисления+1100110 в двоичной системе счисления б) 10001001 в двоичной системе счисления-1010101 в двоичной системе счисления в) 45 в восьмеричной системе счисления * 71 в восьмеричной системе счисления г) 1AF1 в
Ответы (1)
1) Десятичное число 4563 в двоичной системе счисления равно 2) Десятичное число 800 в восьмеричной системе счисления равно 3) Десятичное число 781 в шестнадцатеричной системе счисления равно 4) Двоичное число 1000000 в десятичной системе счисления
Ответы (1)