Задать вопрос
5 февраля, 15:03

С клавиатуры вводится натуральное четырёхзначное число n. Выведите количество четных цифр этого числа

+1
Ответы (1)
  1. 5 февраля, 16:37
    0
    Var

    n, g, s:integer;

    begin

    writeln ('Введите число') ;

    readln (n) ;

    for var i:=1 to 4 do

    begin

    g:=n mod 10;

    if g mod 2=0 then inc (s) ;

    n:=n div 10;

    end;

    writeLn (s) ;

    end.

    нужен другой язык - пиши
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводится натуральное четырёхзначное число n. Выведите количество четных цифр этого числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
1) Найти минимальное число, большее 300, которое нацело делится на 19.2) С клавиатуры вводится натуральное число n. Найти количество цифр этого числа, их сумму, количество четных и нечетных цифр, сколько цифр в числе делится на 3.
Ответы (1)
С клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестс клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестии
Ответы (1)
Дано натуральное число. Определить: а) сколько раз в нем встречается цифра а; б) количество его цифр, кратных z (значение z вводится с клавиатуры; z 2, 3, 4) ; в) сумму его цифр, больших a (значение a вводится с клавиатуры; 0 a 8) ;
Ответы (1)