Задать вопрос
21 мая, 08:00

Триморфное число - число, запись куба которого оканчивается цифрами самого этого числа. Например, 43 = 64, 243 = 13 824, 2493 = 15 438 249. определить, является ли введенное число тримоформным.

+3
Ответы (1)
  1. 21 мая, 09:24
    0
    Как то так получилось

    var n:uint64;

    begin

    read (n) ;

    if (n*n*n mod round ((power (10, inttostr (n). Length))) = n) then writeln ('yes')

    else writeln ('no') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Триморфное число - число, запись куба которого оканчивается цифрами самого этого числа. Например, 43 = 64, 243 = 13 824, 2493 = 15 438 249. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Триморфное число-число, запись куба которого оканчивается цифрами самого этого числа. Например, 4^3=64,24^3=13 824,249^3=15 438 249. определить, является ли введенное число тримоформным.
Ответы (1)
1) Дано число. Получить новое число с обратным значением цифр, где 0→9, 1→8, 2→7, 3→6, 4→5, а цифры 5, 6,7,8,9 не изменяются.
Ответы (1)
1. Составьте программу, проверяющую, что введенное число является четным или нечетным 2. Составьте программу, проверяющую, что введенное число делится без остатка на 3
Ответы (1)
Напишите программу вывода на экран фразы "Число положительное", если введенное число положительное, и "Число отрицательное", если введенное число отрицательное.
Ответы (1)
Разработать программу, реализующую следующий функционал: 1.1. Программа запрашивает у пользователя число от 1 до 10 (n). 1.2. Программа проверяет введенное число на правильность: больше либо равно 1 и меньше либо равно 10. 1.3.
Ответы (1)