Задать вопрос
26 сентября, 11:38

1) Дано число. Получить новое число с обратным значением цифр, где 0→9, 1→8, 2→7, 3→6, 4→5, а цифры 5, 6,7,8,9 не изменяются. (например, число 1379 перепишем как 8679)

2) Триморфное число - число, запись куба которого оканчивается цифрами самого этого числа. Например, 43 = 64, 243 = 13 824, 2493 = 15 438 249. определить, является ли введенное число тримоформным.

+1
Ответы (1)
  1. 26 сентября, 12:18
    0
    Var a, h:longint;

    b:integer;

    begin

    writeln ('введи число') ;

    readln (a) ;

    while a>0 do begin

    b:=a mod 10;

    case b of

    0: b:=9;

    1: b:=8;

    2: b:=7;

    3: b:=6;

    4: b:=5;

    end;

    h:=h*10+b;

    a:=a div 10;

    end;

    a:+0;

    while h>0 do begin

    b:=h mod 10;

    a:=a*10+b;

    h:=h div 10;

    end;

    writeln (a) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Дано число. Получить новое число с обратным значением цифр, где 0→9, 1→8, 2→7, 3→6, 4→5, а цифры 5, 6,7,8,9 не изменяются. (например, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Триморфное число - число, запись куба которого оканчивается цифрами самого этого числа. Например, 43 = 64, 243 = 13 824, 2493 = 15 438 249. определить, является ли введенное число тримоформным.
Ответы (1)
Триморфное число-число, запись куба которого оканчивается цифрами самого этого числа. Например, 4^3=64,24^3=13 824,249^3=15 438 249. определить, является ли введенное число тримоформным.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1) Дано натуральное число. Получить новое, приписав к нему такое же число (например, дано число 234, результат - 234234) 2) Автоморфным называется число, цифры которого совпадают с последними цифрами его квадрата.
Ответы (1)